cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominic Mitchell <...@happygiraffe.net>
Subject Re: problems with "Getting Started" 2.2 [was: Starting out with Cocoon 2.2]
Date Wed, 23 Sep 2009 17:45:55 GMT
On Wed, Sep 23, 2009 at 5:03 PM, Steven D. Majewski <sdm7g@virginia.edu>wrote:

> myBlock1 & myBlock2 seem to have all the right dependencies (and they work
> on their own),
> but myCocoonWebapp has only the jars from those two blocks:
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] [dependency:tree {execution: default-cli}]
> [INFO] edu.virginia.lib:myCocoonWebApp:war:1.0.0
> [INFO] +- edu.virginia.lib:myBlock1:jar:1.0-SNAPSHOT:compile
> [INFO] \- edu.virginia.lib:myBlock2:jar:1.0-SNAPSHOT:compile
> [INFO]
> ------------------------------------------------------------------------
>
> Obviously something is missing from the webapp, but I don't think I missed
> any steps in the tutorial. ( But as I noted in previous message, an earlier
> step or two seem to have been left out. )
>
> I guess I'll go read the maven docs and see if I can find a clue.
>

I think this is happening because you used "mvn install:install-file"
instead of "mvn install".  That would only install the jar file, not the
POM.  Maven needs the POM accessible so it can work out the dependencies.
 That's why they're not showing up when you run "mvn dependency:tree".

-Dom

Mime
View raw message