cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mvalencia <miguel.valen...@juntadeandalucia.es>
Subject Re: problem encoding using SendMailTransformer
Date Fri, 08 Oct 2010 11:36:21 GMT

<map:parameter name="cuerpo" value="{request-param:id_cuerpo}" />
can be the problematic part, since you take the value from the request.

I can remember we applied the tips
http://cocoon.apache.org/2.2/1366_1_1.html once in one of the apps.
AFAIR there should be the  SetCharacterEncodingFilter in your code base.


Yes, SetCharacterEncodingFilter is a filter defined on web.xml of Cocoon
Application:
<filter>
    <filter-name>SetCharacterEncoding</filter-name>
    <filter-class>
      es.sadesi.filter.SetCharacterEncodingFilter</filter-class>
    <init-param>
      <param-name>encoding</param-name>
      <param-value>UTF-8</param-value>
    </init-param>
  </filter>
......
<filter-mapping>
    <filter-name>SetCharacterEncoding</filter-name>
    <servlet-name>DispatcherServlet</servlet-name>
  </filter-mapping>
.....

I have test put encoding on HTML FORM, so with the parameter:
accept-charset="UTF-8" on FORM tag, but it isn't work. It seems encoding
lose when data go to block conector since Cocoon application, but I not
sure.
-- 
View this message in context: http://old.nabble.com/problem-encoding-using-SendMailTransformer-tp29886850p29914526.html
Sent from the Cocoon - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message