cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jasha Joachimsthal <j.joachimst...@onehippo.com>
Subject Re: switch Cocoon 2.2 spring dependencies from 2.5.1 to 2.5.6
Date Fri, 29 Oct 2010 11:05:24 GMT
Spring 2.5.6 has vulnerability issues, see [1]. It's adviced to upgrade to
2.5.6.SEC02.


[1] http://www.springsource.com/security/cve-2010-1622

Jasha Joachimsthal

j.joachimsthal@onehippo.com - jasha@apache.org

Hippo
Europe  •  Amsterdam  Oosteinde 11  •  1017 WT Amsterdam  •  +31 (0)20 522
4466
USA  • San Francisco  185 H Street Suite B  •  Petaluma CA 94952-5100 •  +1
(707) 773 4646
Canada    •   Montréal  5369 Boulevard St-Laurent #430  •  Montréal QC H2T
1S5  •  +1 (514) 316 8966
www.onehippo.com  •  www.onehippo.org  •  info@onehippo.com


On 29 October 2010 07:41, Barbara Slupik <barbara_slupik@wro.vectranet.pl>wrote:

> Hello
>
> The error was caused by the wrong version for ehcache. It works fine with
> ehcache-1.2.4.
>
> I defined spring-2.5.6 dependencies in my application:
>
>    <dependency>
>      <groupId>org.springframework</groupId>
>      <artifactId>spring-web</artifactId>
>      <version>2.5.6</version>
>    </dependency>
>    <dependency>
>      <groupId>org.springframework</groupId>
>      <artifactId>spring-orm</artifactId>
>      <version>2.5.6</version>
>    </dependency>
>    <dependency>
>      <groupId>org.springframework</groupId>
>      <artifactId>spring-jdbc</artifactId>
>      <version>2.5.6</version>
>    </dependency>
>
> instead of changing cocoon poms. It works fine.
>
> Barbara
>
>
> On 19 Oct, 2010, at 11:09 am, Barbara Slupik wrote:
>
>  Hello
>>
>> I am trying to do it but no success so far. I changed spring dependencies
>> in cocoon-6.pom <dependencyManagement>  section but get error when starting
>> my block in jetty. What else do I need to change?
>>
>> Error:
>> 2010-10-19 09:39:10.268:/:INFO:  Initializing Spring root
>> WebApplicationContext
>> 2010-10-19 09:39:11.448::WARN:  failed
>> org.mortbay.jetty.plugin.Jetty6PluginWebAppContext@c4edc7
>> {/,/Developer/Expertys/cocoon-2.2/admin/target/rcl/webapp}
>> java.lang.AbstractMethodError:
>> org.apache.cocoon.tools.rcl.springreloader.SynchronizedConfigureableWebApplicationContext.setConfigLocation(Ljava/lang/String;)V
>>        at
>> org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:253)
>>
>> Barbara
>>
>> On 8 Apr, 2010, at 11:31 am, Thomas Markus wrote:
>>
>>  Hi,
>>>
>>> set your version in dependecyManagement section
>>>
>>> cocoon2.2 with spring 2.5.6 works fine here (since 2 weeks)
>>>
>>> regards
>>> Thomas
>>>
>>> Am 07.04.2010 17:04, schrieb Robby Pelssers:
>>>
>>>> Hi all,
>>>>
>>>> Just wondering if anyone tried to switch to a newer version of spring
>>>> while using Cocoon2.2.  It currently has a dependency on several
>>>> spring-xxx.jar version 2.5.1.
>>>>
>>>> I need to integrate spring-ws within my cocoon application and this is
>>>> giving me headaches (probably) due to dependency conflicts.
>>>>
>>>> So can anyone explain how to make the switch (on Cocoon side) from using
>>>> spring 2.5.1 to spring 2.5.6?
>>>>
>>>> And how big is the risk that Cocoon will not work anymore?
>>>>
>>>>
>>>> Any help is very much appreciated.
>>>>
>>>> Kind regards,
>>>> Robby Pelssers
>>>>
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>>> For additional commands, e-mail: users-help@cocoon.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>> For additional commands, e-mail: users-help@cocoon.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>

Mime
View raw message