cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Chicchiriccò <ilgro...@apache.org>
Subject Re: mvn clean install failure: "Could not resolve dependencies"
Date Fri, 23 Mar 2012 12:49:51 GMT
On 23/03/2012 13:39, Lars Huttar wrote:
> Hi again...
>
> As noted previously, I was able to get C3 running with Francesco's
> instructions (http://markmail.org/message/d6m2yidkrfqkslo2, part C)
> running on my development desktop (using "mvn clean install" instead of
> "mvn clean package"). This is on Win7.
>
> However, on our shared development servers (Win2000), the "mvn clean
> install" step fails.
>
> Here's the part of the error output that seems most relevant (e-17-pub
> is mysite, the block):
>
> [INFO] --- maven-install-plugin:2.3.1:install (default-install) @
> theParent ---
> [INFO] Installing D:\Apache Group\c3\theParent\pom.xml to C:\Documents
> and Setti
> ngs\cocoon\.m2\repository\org\sil\theParent\1-SNAPSHOT\theParent-1-SNAPSHOT.pom
> [INFO]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building e-17-pub 1.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [WARNING] The POM for
> org.apache.cocoon.servlet:cocoon-servlet:jar:3.0.0-beta-1-
> SNAPSHOT is missing, no dependency information available
> [WARNING] The POM for
> org.apache.cocoon.stringtemplate:cocoon-stringtemplate:jar
> :3.0.0-beta-1-SNAPSHOT is missing, no dependency information available
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] theParent ......................................... SUCCESS [0.750s]
> [INFO] e-17-pub ................................. FAILURE [0.234s]
> [INFO] theWebapp ......................................... SKIPPED
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 1.188s
> [INFO] Finished at: Fri Mar 23 07:35:19 CDT 2012
> [INFO] Final Memory: 4M/9M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal on project e-17-pub: Could not resolve d
> ependencies for project org.sil:e-17-pub:jar:1.0-SNAPSHOT: The followin
> g artifacts could not be resolved:
> org.apache.cocoon.servlet:cocoon-servlet:jar:
> 3.0.0-beta-1-SNAPSHOT,
> org.apache.cocoon.stringtemplate:cocoon-stringtemplate:ja
> r:3.0.0-beta-1-SNAPSHOT: Failure to find
> org.apache.cocoon.servlet:cocoon-servle
> t:jar:3.0.0-beta-1-SNAPSHOT in http://download.java.net/maven/2/ was
> cached in t
> he local repository, resolution will not be reattempted until the update
> interva
> l of maven2-repository.java.net has elapsed or updates are forced ->
> [Help 1]
>
> Can someone help me figure out how to fix this?

It seems that maven is trying to download cocoon artifacts from java.net
(http://download.java.net/maven/2/) maven repository where, of course,
they are not available.

This is happening because you probably have, at the end of myparent/pom.xml:

  <repositories>
    <repository>
      <id>maven2-repository.java.net</id>
      <name>Java.net Repository for Maven</name>
      <url>http://download.java.net/maven/2/</url>
      <layout>default</layout>
    </repository>
  </repositories>

Change this to

  <repositories>
    <repository>
      <id>maven2-repository.java.net</id>
      <name>Java.net Repository for Maven</name>
      <url>http://download.java.net/maven/2/</url>
      <layout>default</layout>
    </repository>
    <repository>
      <id>apache.snapshots</id>
      <name>Apache Snapshot Repository</name>
      <url>http://repository.apache.org/snapshots</url>
      <releases>
        <enabled>false</enabled>
      </releases>
    </repository>
  </repositories>

As you can see, we are telling maven that it must consider two
repositories (and we know that missing artifacts are located in this
second repository).

You did not experience this error on the original machine because you
probably performed a "mvn install" of C3 sources, as part of your first
attempts to deal with C3.
This "mvn install" copied C3 artifacts in your local maven repository
and made maven not needing to download them again from Internet.

Regards.

-- 
Francesco Chicchiriccò

Apache Cocoon PMC and Apache Syncope PPMC Member
http://people.apache.org/~ilgrosso/


Mime
View raw message