cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Javier Puerto <>
Subject Re: XSLT import/include errors
Date Thu, 20 Jun 2013 18:34:42 GMT
Hi Greg,

El 20/06/2013 20:00, "gelo1234" <> escribió:
> It looks like XSLT also got cut in functionality in C3. I tried to rerun
old XSL stylesheets with new C3 and gave up.
> The error says nothing meaningful:
> <exception-report class="org.apache.cocoon.pipeline.SetupException"
timestamp="Thu, 20 Jun 2013 19:58:23 +0200"><message>Impossible to read
XSLT from '', see nested
exception</message><cause>Could not compile
Could not compile stylesheet
>     at
>     at
>     at
>     at
>     at
>     at
> It looks like there is a problem with xsl:import/xsl:include from the
main xsl stylesheet.

You are right, seems to be a problem with the imports. I've used Imports
and includes with cocoo3 without problems, except that imported files are
cached and doesn't update running in RCL. The xslt engine is still xalan so
the templates should work like before except for the sources with cocoon:/
protocol that aren't supported.

> Moreover I found that when <xsl:template match="RootElement" is not in
the main XSL stylesheet the same error appears.

Could you send an example block to reproduce the issue?

> Can we switch on more debugging info what is wrong ?

You can edit the logback.xml file and set level to debug but the exception
comes from xalan. I suggest to look for sources loaded with cocoon:/ in
your code and substitute by servlet:/.

> Greetings,
> Greg


View raw message