Hi Greg,

El 20/06/2013 20:00, "gelo1234" <gelo1234@gmail.com> escribió:
>
>
> It looks like XSLT also got cut in functionality in C3. I tried to rerun old XSL stylesheets with new C3 and gave up.
>
> The error says nothing meaningful:
>
> <exception-report class="org.apache.cocoon.pipeline.SetupException" timestamp="Thu, 20 Jun 2013 19:58:23 +0200"><message>Impossible to read XSLT from 'javax.xml.transform.stream.StreamSource@cba24d', see nested exception</message><cause>Could not compile stylesheet</cause><stacktraceCause>javax.xml.transform.TransformerConfigurationException: Could not compile stylesheet
>     at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerFactoryImpl.newTemplates(Unknown Source)
>     at org.apache.cocoon.sax.component.XSLTTransformer.load(XSLTTransformer.java:216)
>     at org.apache.cocoon.sax.component.XSLTTransformer.load(XSLTTransformer.java:165)
>     at org.apache.cocoon.sax.component.XSLTTransformer.setConfiguration(XSLTTransformer.java:264)
>     at org.apache.cocoon.sitemap.InvocationImpl.installComponent(InvocationImpl.java:257)
>     at
>
> It looks like there is a problem with xsl:import/xsl:include from the main xsl stylesheet.

You are right, seems to be a problem with the imports. I've used Imports and includes with cocoo3 without problems, except that imported files are cached and doesn't update running in RCL. The xslt engine is still xalan so the templates should work like before except for the sources with cocoon:/ protocol that aren't supported.

> Moreover I found that when <xsl:template match="RootElement" is not in the main XSL stylesheet the same error appears.

Could you send an example block to reproduce the issue?

>
> Can we switch on more debugging info what is wrong ?

You can edit the logback.xml file and set level to debug but the exception comes from xalan. I suggest to look for sources loaded with cocoon:/ in your code and substitute by servlet:/.

>
> Greetings,
> Greg

Salu2.