commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ringo.des...@mediagenix.com
Subject RE: [lang] Unit test coding conventions?
Date Fri, 05 Jul 2002 13:32:40 GMT

> Any ideas on naming schemes? Do I just do:
> 
> testCapitalize1
> testCapitalize2
> 
> or
> 
> testCapitalizeNullExceptionWithFirstArgumentNull etc?

At the office, I use both. But if I use the numbered versions, I document
the test method if you can't directly deduce from the method body what is
tested. Mostly, I used the descriptive test method name because I don't have
to write additional javadoc. Aren't we all lazy? :)

Ringo

--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@jakarta.apache.org>


Mime
View raw message