commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ASHWIN Suresh <a.sur...@sigmatel.net.ma>
Subject RE: [collections] pairs package name
Date Wed, 03 Dec 2003 19:36:28 GMT
"data" would be fine but somehow I feel a name like that is too generic. 
I mean, it's all data! So, the name did rather describe what the classes do
with data.

So, one might call it: 
oacc.dataholders

Or, if that is long, how about just  oacc.holders

Or something that describes that these elements hold/have data.

Ash


> -----Original Message-----
> From: __matthewHawthorne [mailto:matth@phreaker.net]
> 
> 
> o.a.c.c.data could work.
> 
> some other ideas:
> o.a.c.c.types
> o.a.c.c.elements

> 
> 
> Stephen Colebourne wrote:
> > KeyValue is not directly associated with maps - its a free 
> form key value
> > pair. MultiKey could also be used in a List or Set.
> > 
> > Stephen
> > 
> > ----- Original Message -----
> > From: "Rodney Waldhoff" <rwaldhoff@apache.org>
> > 
> >>Why can't these all just go with the maps?
> >>
> >>On Wed, 3 Dec 2003, Stephen Colebourne wrote:
> >>
> >>
> >>>The pairs package name is perhaps not quite right. I would like the
> > 
> > package
> > 
> >>>to hold all non-collection data structure:
> >>> - MapEntry
> >>> - KeyValue
> >>> - MultiKey
> >>>
> >>>How about renaming the package to data?
> >>>(no backwards compatability issues)
> >>>
> >>>Stephen
> >>>
> >>>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message