commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ASHWIN Suresh <a.sur...@sigmatel.net.ma>
Subject RE: [lang][collections][primitives] etc, JDK compatibility query - class
Date Mon, 08 Dec 2003 20:24:03 GMT
The  1.4 class is java.util.LinkedHashMap in
org.apache.commons.collections.MapPerformance.
Perhaps it's a test class. I don't know whether the compatibility question
is the same
wrt test classes.
Ash



> -----Original Message-----
> From: ASHWIN Suresh 
> Sent: Monday, December 08, 2003 19:12
> To: 'Jakarta Commons Developers List'
> Subject: RE: [lang][collections][primitives] etc, JDK compatibility
> query
> 
> 
> Right. Even I wanted to suggest that it is better to keep off 
> 1.4 for a
> while.
> 
> I came up with the query because I found a 1.4 class used in 
> one of the
> classes
> in the collections package. One of the 
> java.util.LinkedSomething. Sorry I
> forgot.
> But my JDK1.3 setup didnt run when I was trying to build yest 
> night. Maybe
> it's 
> temporary?, or maybe someone forgot??
> 
> Ash
> 
> 
> 
> > -----Original Message-----
> > From: Paul Libbrecht [mailto:paul@activemath.org]
> > Sent: Monday, December 08, 2003 19:01
> > To: Jakarta Commons Developers List
> > Subject: Re: [lang][collections][primitives] etc, JDK compatibility
> > query
> > 
> > 
> > Rodney Waldhoff wrote:
> > > I'm strongly opposed to requiring JDK 1.4 at this time in 
> > collections or
> > > primitives.  I don't use or contribute to lang, but I 
> > suggest it's a bad
> > > idea there too.
> > > 
> > > On Mon, 8 Dec 2003, Ash .. wrote:
> > > 
> > > 
> > >>I wish to know what the compatibility objectives of the 
> > forthcoming releases
> > >>for the components lang, collections, and primitives are. 
> > Specifically, will
> > >>they necessitate use of JDK 1.4?
> > 
> > My +1 against 1.4 requirement.
> > MacOSX has been on the edge of java for a while (is almost 
> > still, now in 
> > 1.4.2 beta). Starting to require 1.4 would mean you need 
> > MacOSX 10.2... 
> > something that several MacOSXers might not have.
> > (VMs are made by Apple on Mac, and only by them)
> > 
> > Staying 1.3 means requiring any MacOSX.
> > Sad thing is that you still have ot live with xml-api then.. ah 
> > well...Aside of this, I wonder who would require 1.4... 
> FocusManager? 
> > Speedier GUI? Preferences?
> > 
> > Paul
> > 
> > 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message