commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ash .." <>
Subject [lang] new StringBuffer.. what to call it
Date Thu, 11 Dec 2003 19:29:08 GMT

>BTW: MutableString is a bad name as it can imply a class that holds a 
and has a getString and setString method.


Can you tell us why the name MutableString implies it has a getString and 

And what do people think here of introducing a different term (say Strand) 
for this concept as I discussed earlier (I paste that here, last time it was 
buried under confusion due to a typo.)

Talking about name, I would add my opinion that while it might be
nice to have a name for the replacer that is much like the replacee,
(StringBuf) one might prefer a more descriptive name at the expense
of this convenience: (***  MutableString).

As a compromise between the two, the name Strand can be adopted (Str...
thus near the original one + can be defined to represent a mutable
string contrasted with "String" which, by virtue of the so-named
class in the API, is immutable.)



Run, rabbit run.
Dig that hole, forget the sun,
And when at last the work is done
Don't sit down it's time to dig another one.

Our best dial-up offer is back.  Get MSN Dial-up Internet Service for 6 
months @ $9.95/month now!

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message