commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 32881] - [chain] Provide a mechanism for encoding catalog and command in a single string
Date Wed, 29 Dec 2004 22:48:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32881>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32881





------- Additional Comments From craig.mcclanahan@sun.com  2004-12-29 23:48 -------
Suggestions on the proposed patch:

* Declare the delimiter as a manifest String constant:

  public static final String DELIMITER = ':';

* In getCommand(), treat a String with zero delimiters
  as the name of a command in the default catalog.  No
  need to support a syntax that starts with a ':' character,
  unless you happen to define a catalog whose name is a
  zero-length string.

* In getCommand(), treat a String with one delimiter
  as the concatenation of a catalog name and a command
  name, but return null if one or both cannot be found
  (i.e. don't try to change the interpretation to the
  entire string as a command name).

* In getCommand(), treat a String with more than one
  delimiter as an error (reserving that syntax for
  future use), and throw IllegalArgumentException.



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message