commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 36819] - [configuration] Interpolation with multivalued keys returns nested strings instead of flattend string and interpolate doesn't work with all getters
Date Tue, 27 Sep 2005 12:29:12 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=36819>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=36819





------- Additional Comments From oliver.heger@t-online.de  2005-09-27 14:29 -------
An Object interpolate(Object) method will be needed in future anyway, that's
fine with me.

What resolveContainerStore() does ATM is to prepare a property value as far as
possible, so that primitive getters only need to perform a type conversion.
Performing interpolation is part of this task IMO. I would prefer having all
these steps at a central place to reduce code duplication.

However "resolveContainerStore" is surely the wrong name for this method.
Because of backwards compatibility we cannot simply change the name. Should we
deprecate the method and instead introduce a new one with a better name?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message