commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <>
Subject [Jakarta-commons Wiki] Update of "VfsNext" by MarioIvankovits
Date Mon, 14 Nov 2005 19:22:17 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Jakarta-commons Wiki" for change notification.

The following page has been changed by MarioIvankovits:

New page:
= VFS - Next =

== apply ==
ram filesystem

== apply ==
services & svn filesystem

we need a discussion about a new name instead of "services"
The idea is to have a call like

Commit commitFile = FileObject.getService(Commit.class)


TumbnailImage thumb = FileObject.getService(TumbnailImage.class)
Image bi = thumb.getImage();

You get the idea?

The current name proposals are:

 * serivce - getService()
 * aspect - getAspect()

== caching review - allow to configure fileObjects internal state cache ==
This is to avoid the .close() calling to get fresh data.

Sure, this might slow down alot, but if one would like have it, it should be possible.

== user api ==
a way to avoid to put username/password into the url.

Using a callback mechanism to get this data when needed.

== progress & cancellation api ==
callbacks to be informed about ongoing operations (copy, move, rename, delete, copy-progress,
move-progress (if between filesystems))

== file permissions (non-native) ==
(with non native code only)

figure out a way to represent file permissions and a way to modify then

== browse roots ==
e.g. smb or local partitions (windows - c:, d:, ...)

== native parts (if possible through jdic) ==
 * filesystem notifications - to get informed about external filesystem events
 * file permissions to allow fine grained setup for local files

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message