commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Andersson>
Subject [daemon] help getting jsvc up and running on sles9 on ibm pseries (power5)
Date Mon, 12 Jun 2006 10:08:32 GMT
Hi there, I have a small problem that I'. hoping that you can help me solve.

I want to be able to run tomcat on a server that we have available at a
hosting firm.

I can get tomcat up and running on it witohut problem, as long as I
don't try to use jsvc..  and I need jsvc sicne I don't want to run tomat
as root, or manually start tomcat whenever there is a restart of the
server, etc..

I've tried compiling the jsvc that comes with tomcat, but no luck, so I
downloaded deamons 1.0.1 and tried to get that compiling, and still no
luck, after searching/following different hints that I found on the net
(I'll ge over those later) I do get jsvc compiled, but I still cannot
run it, because it looks like jsvc is compiled as a 32 bit binary and
the ibm-java that I have is a 64 bit binary.

anyway here is a list of what I've done (not much)

after downloading and unpacking jsvc I went into
daemon-1.0.1/src/native/unix and did a ./configure

and got the following result..

*** Current host ***
checking build system type... ./support/config.guess: unable to guess
system type

This script, last modified 2001-04-20, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

If the version you run (./support/config.guess) is already up to date,
send the following data and any information you think might be
pertinent to <> in order to provide the needed
information to handle your system.

config.guess timestamp = 2001-04-20

uname -m = ppc64
uname -r = 2.6.5-7.252-pseries64
uname -s = Linux
uname -v = #1 SMP Tue Feb 14 11:11:04 UTC 2006

/usr/bin/uname -p =
/bin/uname -X     =

hostinfo               =
/bin/universe          =
/usr/bin/arch -k       =
/bin/arch              = ppc64
/usr/bin/oslevel       =
/usr/convex/getsysinfo =

UNAME_RELEASE = 2.6.5-7.252-pseries64
UNAME_VERSION = #1 SMP Tue Feb 14 11:11:04 UTC 2006
configure: error: cannot guess build type; you must specify one

after downloading the newest config.guess from*checkout*/config/config/config.guess
(the above specified link leads to this file) and replacing the existing
one in  daemon-1.0.1/src/native/unix/support and once more execute
configure I get the following...

*** Current host ***
checking build system type... powerpc64-unknown-linux-gnu
checking host system type... powerpc64-unknown-linux-gnu
checking cached host system type... ok
*** C-Language compilation tools ***
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
*** Host support ***
checking C flags dependant on host system type... failed
configure: error: Unsupported CPU architecture "powerpc64"

following information on the net it was suggested that I change the
configure script so that it accepts powerpc* instead of powerpc
that is from
  case $host_cpu in
    CFLAGS="$CFLAGS -DCPU=\\\"$host_cpu\\\"" ;;
  case $host_cpu in
    CFLAGS="$CFLAGS -DCPU=\\\"$host_cpu\\\"" ;;

the result:

*** All done ***
Now you can issue "make"

make also succedes, but when running jsvc using the script that comes
with apache tomcat (modified to suite my needs ofcourse) no jsvc is
running, and in the error log I find the following...

12/06/2006 11:58:15 19502 jsvc.exec error: Cannot dynamically link to
12/06/2006 11:58:15 19502 jsvc.exec error:
/opt/ibm/java2-ppc64-50/jre/bin/classic/ cannot open sha
red object file: No such file or directory
12/06/2006 11:58:15 19501 jsvc.exec error: Service exit with a return
value of 1

and in /opt/ibm/java2-ppc64-50/jre/bin/classic these files exist

-rwxr-xr-x  1 root root 238290 2006-03-10 16:50

so it should be able to find the file since the user that I'm running
this fron is able to find it in the correct location. and can read it.

for me this now looks like jsvc is beeing compiled as a 32bit executable
but java is a 64bit executable..

I've tried reading/changing more stuff to get it working, but sofar I
have been unable to do so.

so please to any of you withing the daemons project, I need help :-)

/Christian Andersson

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message