commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joerg Heinicke <joerg.heini...@gmx.de>
Subject Re: [transaction] Release plan?
Date Sat, 15 Jul 2006 10:58:47 GMT
Oliver Zeigermann <oliver.zeigermann <at> gmail.com> writes:

> > Also what is the minimum JDK version for transaction?
> 
> I used ant for the previous releases (target package). Minimum jdk is 1.2

Has anybody actually been checking this? Setting those properties has probably
influence on the compiler (e.g. complain about newer language constructs
(asserts, etc.) and the generated bytecode), but not on the available API I
think. Despite bytecode compatibility you might end with ClassNotFoundExceptions
and NoSuchMethodExceptions when using JDK 1.3+ API.

Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Mime
View raw message