commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell" <>
Subject Re: [lang] VariableFormatter - pre 2.2
Date Wed, 02 Aug 2006 20:59:55 GMT
On 8/2/06, Gary Gregory <> wrote:
> Hello All:
> I think the argument for the name change I am hearing is: we are not
> formatting a la printf but we are replacing markers with values (and not
> formatting those values). Is that right? If that is the case, a
> "Substitutor" name is better.
> As a general rule, I do not like or use abbreviations in class or method
> names (acronyms are OK by me). So I would say that StringSubstitutor is
> better. After all, we have "StringUtils", "StringEscapeUtils" and many
> others, not "StrUtils", "StrEscapeUtils". So I would ask that we use
> "StringFoo" for all of these classes.

I think in some places it was to avoid clash with JDK 1.5.
StringBuilder I presume being the one.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message