commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Carman" <ja...@carmanconsulting.com>
Subject Re: [configuration] artifactId on the 2.x branch
Date Sun, 17 Feb 2008 01:23:18 GMT
On 2/16/08, Emmanuel Bourg <ebourg@apache.org> wrote:
> James Carman a écrit :
> >  I just tried a test by putting in commons-collections 3.1 and 3.2 as
> > dependencies.  When I listed the dependencies (using the maven
> > plugin), I only see 3.2.  So, I guess we have to change the artifact
> > id too.
>
> That's slightly different since both artifacts are in the same
> commons-collection group. Tomorrow if a project depends on the artifacts
> commons-configuration 1.5 (in the commons-configuration group) and
> commons-configuration 2.0 (in the org.apache.commons group), Maven will
> use both artifacts I think, and not only the latest revision. Thus
> renaming the artifact doesn't seem necessary to me, but I may be missing
> something.
>

I understand what you mean (that changing it isn't really necessary
right now), but maybe we should try to be consistent.  If we're going
to have to start changing the artifactId going forward (since we won't
be changing the groupId) anyway, then maybe we should just go ahead
and start changing it now.

> Emmanuel Bourg
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message