commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "" <>
Subject Re: [nabla] unable to update site with maven
Date Wed, 07 May 2008 11:36:55 GMT schrieb:
> Hello,
> I tried yesterday to update the nabla site and failed. I wanted to have the
> current state of documentation published as soon as possible.
> I used the command "mvn deploy" after having set up my username and private key
> file in ~/.m2/settings.xml, but was asked for a password instead of my
> passphrase to read the file. I even tried to put the passphrase temporarily in
> my settings.xml file but this didn't change anything. Entering my password for
> the host didn't work either. I am able to log on the host
> using directly ssh and my private key. My key is an RSA key, I didn't try to set
> up a DSA key yet.
> Is "mvn deploy" the right command ? Does anybody have an idea of what I have
> done wrong ?

If you are trying to update the nabla site, then
  "mvn site-deploy"
is what you need.

The command
  "mvn deploy"
will deploy the jarfiles to the repository (the snapshot repository if
the pom's version contains -SNAPSHOT, and the production repo otherwise).

Sorry, don't know why you are being prompted for a password.

The nabla pom has the distribution-management set to:


so you need to configure login details in your ~/.m2/settings.xml which
allow scp to that location. Maybe you have the username set wrong?
Unless overridden, maven will try to use your local username as the name
to log in with. This has caught me out a few times..


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message