commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <>
Subject Re: [math] duplicate DimensionMismatchException
Date Sun, 01 Aug 2010 18:04:23 GMT
> It appeared to me a new DimensionMismatchException has been added in the
> exception package. There was already a class with that name in the top
> level package since 1.2.
> Could the new class be renamed to avoid a name clash ?

I named it the same on purpose: so that one just have to change the "import"
statement. Hopefully, one should never need to use them both in the same
The old class should be deprecated (now) and removed (in 3.0). [IMO, it was
a mistake to create a checked exception in order to signify a precondition


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message