commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <>
Subject Re: [configuration] Compilation under Java 1.4
Date Wed, 09 Feb 2011 22:42:57 GMT
The latest versions of Maven require JDK 1.5.  The pom (or the Commons Parent) should be specifying
that the target for Commons Configuration is 1.4.  I've run this build many times successfully
(I use 1.6).  I don't see any problem requiring the build to use Maven 2.2.x or Maven 3 and/or
have a minimum JDK version for that.  I would have a problem if this prevented the result
from running in a JDK 1.4 VM.


On Feb 9, 2011, at 1:25 PM, Oliver Heger wrote:

> Hi,
> because of the dependency to VFS 2.0 (SNAPSHOT) which requires Java 1.5, it is currently
not possible to build [configuration] with a JDK 1.4: the vfs jar causes a bad class version
> I am not sure what would be the best strategy to solve this problem. Probably we need
some Maven magic to compile some classes with a different JDK. Or should we simply make a
multi-module project with a separate module for the classes depending on vfs? But this would
create another artifact.
> Oliver
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message