commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elijah Zupancic <>
Subject Re: [chain] Upgrading to Maven parent version 21
Date Sun, 31 Jul 2011 15:06:30 GMT
Here is the output from SVN diff:

Index: pom.xml
--- pom.xml	(revision 1152492)
+++ pom.xml	(working copy)
@@ -21,7 +21,7 @@
-        <version>15</version>
+        <version>21</version>

I'm getting the same result with:

OpenJDK Runtime Environment (IcedTea6 1.9.8) (6b20-1.9.8-0ubuntu1~10.10.1)
OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)


java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) 64-Bit Server VM (build 14.2-b01, mixed mode)

Also, I'm building against

I'm on Ubuntu 10.10.

I have manually the the digester version higher, and all tests passed.
It is only when I upgrade the parent pom that this test fails. This is
even more curious now that I hear it is working on your OS X system.
When I get access to another machine, I will try it elsewhere next
week. Right now, I'm out in the countryside with not a lot of


On Sun, Jul 31, 2011 at 12:16 AM, Phil Steitz <> wrote:
> On 7/30/11 11:13 AM, Elijah Zupancic wrote:
>> As part of my refactoring project with Apache Chain, I've been trying
>> to update dependency versions. I tried to upgrade the maven parent
>> configuration and the compile worked fine, but I have been getting a
>> really odd unit test failure. Moreover, I did a diff between maven
>> parent pom.xml versions and nothing stood out to me as to why the
>> parent pom would cause this.
> What OS and JDK are you using?  When I change the pom in trunk to
> use commons-parent version 21 (with no other changes) all of the
> tests run clean for me on OS X 10.7,
> java version "1.6.0_26"
> Java(TM) SE Runtime Environment (build 1.6.0_26-b03-383-11A511)
> Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02-383, mixed mode)
> Digester version in the pom in trunk is 1.8.  I also tested with 2.0
> and 2.1 and did not see failures with JDK above.
> Are you sure there are no other changes in the sources you are
> testing against?  Does svn diff turn up any other differences?
> Phil
>> Results :
>> Failed tests:
>> testDefaut(org.apache.commons.chain.config.ConfigParserTestCase)  Time
>> elapsed: 0.034 sec  <<< FAILURE!
>> junit.framework.AssertionFailedError: Correct command count
>> expected:<17> but was:<19>
>>         at
>>         at junit.framework.Assert.failNotEquals(
>>         at junit.framework.Assert.assertEquals(
>>         at junit.framework.Assert.assertEquals(
>>         at org.apache.commons.chain.config.ConfigParserTestCase.checkCommandCount(
>>         at org.apache.commons.chain.config.ConfigParserTestCase.testDefaut(
>> The XML file it is reading for commands contains exactly 17 commands,
>> so the data source is correct. Before I start to peel apart the XML
>> parser, I was wondering if anyone else encountered this before. Do any
>> of you have any insight into this?
>> Thanks,
>> -Elijah
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail:
>> For additional commands, e-mail:
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message