commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elijah Zupancic <eli...@zupancic.name>
Subject [chain] Upgrading to Maven parent version 21
Date Sat, 30 Jul 2011 18:13:06 GMT
As part of my refactoring project with Apache Chain, I've been trying
to update dependency versions. I tried to upgrade the maven parent
configuration and the compile worked fine, but I have been getting a
really odd unit test failure. Moreover, I did a diff between maven
parent pom.xml versions and nothing stood out to me as to why the
parent pom would cause this.

Results :

Failed tests:
testDefaut(org.apache.commons.chain.config.ConfigParserTestCase)  Time
elapsed: 0.034 sec  <<< FAILURE!
junit.framework.AssertionFailedError: Correct command count
expected:<17> but was:<19>
        at junit.framework.Assert.fail(Assert.java:47)
        at junit.framework.Assert.failNotEquals(Assert.java:282)
        at junit.framework.Assert.assertEquals(Assert.java:64)
        at junit.framework.Assert.assertEquals(Assert.java:201)
        at org.apache.commons.chain.config.ConfigParserTestCase.checkCommandCount(ConfigParserTestCase.java:316)
        at org.apache.commons.chain.config.ConfigParserTestCase.testDefaut(ConfigParserTestCase.java:116)


The XML file it is reading for commands contains exactly 17 commands,
so the data source is correct. Before I start to peel apart the XML
parser, I was wondering if anyone else encountered this before. Do any
of you have any insight into this?

Thanks,
-Elijah

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message