commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S├ębastien Brisard <>
Subject [math] RealVector.toArray() vs. RealVector.getData()
Date Wed, 07 Sep 2011 02:19:53 GMT
as noted in MATH-653, these two methods are redundant, and one should
go. Pros and cons are
* toArray() is fairly classical in the Java world
* but getData() is consistent with ArrayRealVector.getDataRef().
Personnaly, my preference goes to keeping toArray(). In order to
maintain consistency, should ArrayRealVector.getDataRef() be renamed
getArrayRef() ?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message