commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Dunning <>
Subject Re: [math] rename o.a.c.m.linear.SingularMatrixException to SingularLinearOperatorException
Date Sun, 02 Oct 2011 07:20:38 GMT
On Sat, Oct 1, 2011 at 10:58 PM, Phil Steitz <> wrote:

> > As for shortening the name, I'm all for it. For consistency, I would
> > do it for every class matching the pattern *LinearOperator* if you all
> > agree. Also, I think that "linear" is as important as "operator" in
> > "LinearOperator" (even if lilnearity might seem an obvious feature,
> > provided all the classes we are discussing are actually located in the
> > linear package). So what do you think of LinOp as a compromise?
> > Something like RealLinOp instead of RealLinearOperator,
> > NonSquareLinOpException, etc...
> I like full words.   I don't know about "linear" vs "operator" in
> "LinearOperator" but I think the "linear" can safely be dropped in
> "SingularLinearOperator."

Abbreviations don't really shorten names.  They just make them impossible
for non-native speakers to guess.  And if abbreviations are done by
non-native speakers, they become impossible for anybody to guess.

+1 to avoiding abbreviations where possible.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message