commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S├ębastien Brisard <>
Subject [math] Possible confusions in GammaDistribution
Date Wed, 16 May 2012 05:47:01 GMT
while working on MATH-753, I found that some methods
o.a.c.m3.distribution.GammaDistribution were ill-named. Indeed, the
class javadoc explicitly refers to the Wikipedia page. In this page,
the shape parameter is named alpha and the scale parameter is 1 / beta
(inverse of beta), while in the current implementation, the shape
parameter is named alpha, and the scale parameter is named beta (not 1
/ beta !!!). This might be confusing. Looking at other web pages, I
see there is apparently no consensus on the naming of shape and scale
parameters. The problem lies with the accessors, which are
double getAlpha()
double getBeta()

I think these accessors can lead to confusion. I would therefore
propose to deprecate them, and replace them with
double getShape()
double getScale()

What do you think ?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message