commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <>
Subject Re: [graph] renaming packages
Date Fri, 03 Aug 2012 13:00:07 GMT

> Also remember that if we ever want to deal with, say, multiplications,
> monoids are only going to be in the way (we already touched this topic
> before, see [1]). I'm still happy to update and simplify names, only
> following a different pattern: e.g. from "DoubleWeightBaseOperations" to
> "DoubleOperations". And I'd also replace "Monoid" with "Addition".

yeah thanks of the reminder - I was searching for it in the mail
archives and didn't find it :P

wouldn't "Multiplication" have exactly the same methods signature of
"Addition" aka Monoid? I wouldn't replicate stuff just to implement
Anyway I agree that algorithms need specific monoids, such as Dijkstra
that needs Addition - guess it wouldn't work with Subtractions :P

What about having Monoid with package visibility and then
"Addition/Multiplication... extends Monoid" ?

> After thinking a bit I'm also a bit perplexed about renaming "builder" to
> "connect", and in general about the name of the method "connect()". You
> know the meaning of "connected" in graph theory, while with our method we
> could actually create a graph which is not connected (e.g. one with no
> edges at all).


> So I suggest to look for a less ambiguous alternative:
> "populate" (this gets my vote)? "declare"? "construct"? "assemble"?

+1 to "populate" (and related class renaming?)

thanks a lot for your feedbacks and enjoy vacations!

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message