commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luc Maisonobe <...@spaceroots.org>
Subject Re: [all] strange maven magic
Date Mon, 13 May 2013 13:11:50 GMT
Hi Vishwa,

Le 13/05/2013 14:51, Vishwanath Krishnamurthi a écrit :
> New to the list, so first a "hello" to all :)

Welcome!

> 
> @Luc
> Guess the default is just to run the tests.
> The project you were saying about where tests do not run by default -
> probably has a property in the pom to skip tests.

I don't see any such property (neither in the project pom nor in my
settings).

Luc

> 
> -Vishwa
> 
> On Mon, May 13, 2013 at 5:26 PM, Luc Maisonobe <luc@spaceroots.org> wrote:
> 
>> Hi all,
>>
>> In the last few days, I looked into the commons parent pom as well as
>> several other poms to set up JaCoCo reports. There is something I don't
>> understand: with our current setting at Apache, when we run "mvn clean
>> site", the tests are automatically run. In another non-Apache project,
>> when I do the same thing, tests are not run, and I have to manually run
>> them before building the site.
>>
>> Could someone explain me what we did to have this magic happen in commons?
>>
>> Luc
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message