commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Carman <>
Subject Re: svn commit: r1528612 - /commons/sandbox/monitoring/trunk/reporting/src/main/java/org/apache/commons/monitoring/reporting/web/plugin/
Date Fri, 04 Oct 2013 22:33:31 GMT
Also, since when did we start nit-picking code in the sandbox?  Why
not leave these folks alone and let them work out their ideas?  The
sandbox should be an area where folks can play around with stuff and
share new ideas without being hassled by folks.  If we make it a pain
in the butt, then people will just go elsewhere with their cool ideas.
 It's one thing if you're collaborating on the project, but trolling
commit logs and picking out things you don't like is just plain rude,

On Fri, Oct 4, 2013 at 6:23 PM, James Carman <> wrote:
> On Fri, Oct 4, 2013 at 6:11 PM, sebb <> wrote:
>> Back to the case in point: why is the string ".activate" and not anything else?
> Why not just extract a constant and name it something logical like
> "ACTIVATED_INDICATOR"?  Then, the actual value of the constant can be
> whatever you want.  The value of the string isn't important (other
> than making it a bit more human-readable of course).  What is
> important is that you use the string in a consistent fashion
> throughout your code.  By not using a constant, it makes it more
> likely to fat-finger the value when you type it again somewhere.
> Anyway, I'm sure I'm not telling you anything new.  I just don't think
> it's relevant to go into a lengthy discussion about the string that's
> used as some sort of marker.  Just extract the constant (and use it)
> and move on.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message