commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruno P. Kinoshita" <>
Subject Re: [VOTE] Release Configuration 2.0-beta1 based on RC1
Date Mon, 15 Jun 2015 08:34:29 GMT

-1 not binding

The following test fails in Ubuntu 14.04 with Java versions: 

* 1.8.0_45, vendor: Oracle Corporation, Java home: /usr/lib/jvm/java-8-oracle/jre* 1.7.0_79,
vendor: Oracle Corporation Java home: /opt/jdk1.7.0_79/jre* 1.6.0_45, vendor: Sun Microsystems
Inc. Java home: /usr/lib/jvm/java-6-oracle/jre

And Maven:
Apache Maven 3.2.5 (12a6b3acb947671f09b81f49094c53f426d8cea1; 2014-12-15T06:29:23+13:00)

Failed tests: 
  TestDefaultFileSystem.testGetOutputStreamInvalidPath Expected exception: org.apache.commons.configuration2.ex.ConfigurationException

Tried with 
* 1.7.0_79, vendor: Oracle Corporation Java home: /opt/jdk1.7.0_79/jre
And Maven
Apache Maven 3.3.3 (7994120775791599e205a5524ec3e0dfe41d4a06; 2015-04-22T23:57:37+12:00)

But the test still failed.
Running in Eclipse to investigate it, looks like it tries to create a `new File("this is/<certainly>\\an#invalid#*path!")`
and is expecting for an exception.

Looking in my workspace I can see that Java successfully created some directories:
kinow@chuva:/tmp/CONFIGURATION_2_0_beta1_RC1$ ls -R thi*
this is:
i.e. a directory "this is" was created, with a child directory "<certainly>\an#invalid#*path!"
Later it fails to `rm` the child directory due to its name, so you need to delete it by its
inode: cd this\ is && find -inum $(ls -i | awk '{print $1}') -exec rm {} \;
One simple solution might be replace
new File("this is/<certainly>\\an#invalid#*path!")

new File("")
Which is an invalid path too.

      From: Oliver Heger <>
 To: Commons Developers List <> 
 Sent: Monday, June 15, 2015 8:10 AM
 Subject: [VOTE] Release Configuration 2.0-beta1 based on RC1
Hi all,

this is a vote for the first beta version of [configuration] 2.0 based
on the first release candidate. After two alpha versions, it is now time
to move to a beta version. Since the last alpha version, there has only
be a small change: an obsolete interface has been removed. Details are
available in the release notes.

Switching to beta indicates that we expect the interfaces to become more
stable. However, there is still not yet a guarantee that there will be
no more changes on the API.

Because this is a beta and not yet an official release I did not deploy
the artifacts to Nexus; only the distributions were created.

Configuration 2.0-beta1 RC1 is available for review here:
(revision 9374)

Details of changes since 1.10 and the alpha versions are in the
release notes:

Here is the tag:
(revision 1685450)

(note some links in the menu for version 1.10 are not yet working)


Please review the release candidate and vote.
This vote will close no sooner than 72 hours from now, i.e. after 2000
GMT 17-June 2015

  [ ] +1 Release these artifacts
  [ ] +0 OK, but...
  [ ] -0 OK, but really should fix...
  [ ] -1 I oppose this release because...


To unsubscribe, e-mail:
For additional commands, e-mail:


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message