commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Wiedmann <jochen.wiedm...@gmail.com>
Subject Fwd: [ALL] About binary compatibility
Date Mon, 06 Jun 2016 18:11:54 GMT
---------- Forwarded message ----------
From: Ralph Goers <ralph.goers@dslextreme.com>
Date: Mon, Jun 6, 2016 at 1:11 AM
Subject: Re: [ALL] About binary compatibility
To: Commons Developers List <dev@commons.apache.org>


I think we should adopt Java 9’s multi-release jars [1] as standard
practice.  While this won’t let us update our APIs without breaking
compatibility (which may still be necessary), it will allow us to
leverage some features in newer versions of Java without worrying
about breaking backward compatibility.

Strong disagreement. Java 9 is not even out, and I heard noone express
any desire to *use* these beasts. In other words: We'd serve a
non-existing demand. That can't help anyone,
in particular not ourselves.

Jochen

-- 
The next time you hear: "Don't reinvent the wheel!"

http://www.keystonedevelopment.co.uk/wp-content/uploads/2014/10/evolution-of-the-wheel-300x85.jpg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message