commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benedikt Ritter <brit...@apache.org>
Subject Re: clirr-maven-plugin fails - update to 2.8?
Date Mon, 26 Sep 2016 15:33:46 GMT
Hi,

Gary Gregory <garydgregory@gmail.com> schrieb am Mo., 26. Sep. 2016 um
17:29 Uhr:

> We have 3 issues:
>
> - Updating the commons-parent to effectively require Java 7 so we can run
> Clirr or an equivalent tool
>

I think this is not an issue, because we have profiles that get activated
for more recent JDKs, which use more recent plugins.


>
> - Should we still be using Clirr since it is not maintained?
> http://clirr.sourceforge.net/ shows "Last published: 27 September 2005 |
> Doc for 0.6".
>   With BeanUtils 1.9.3, we used JApiCmp:
> https://commons.apache.org/proper/commons-beanutils/japicmp.html


That's a good one. We had a discussion about the future of Clirr a while
back, with no clear result. JApiCmp may be a good alternative.


>
>
> - Should we use the Animal Sniffer plugin for all components to build with
> a more recent Java version than the one the component requires and still
> check that the code does not use new Java APIs?
>

Yes.

Regards,
Benedikt


>
> Gary
>
> On Sep 26, 2016 4:03 AM, "Stian Soiland-Reyes" <stain@apache.org> wrote:
>
> > On 23 September 2016 at 19:49, Gary Gregory <garydgregory@gmail.com>
> > wrote:
> > > There is no Clirr report but 'mvn clirr:check' runs OK.
> >
> > In BeanUtils I used jacoco as clirr-maven-plugin:2.7 fails in JDK8:
> >
> > [INFO] Generating "Clirr" report                ---
> > clirr-maven-plugin:2.7:clirr
> > [INFO] Comparing to version: 1.9.2
> > [ERROR] Failed to execute goal
> > org.apache.maven.plugins:maven-site-plugin:3.4:site (default-site) on
> > project commons-beanutils: Execution default-site of goal
> > org.apache.maven.plugins:maven-site-plugin:3.4:site failed: Invalid
> > byte tag in constant pool: 18 -> [Help 1]
> >
> >
> > Since then clirr-maven-plugin 2.8 has just been released; which uses
> > Commons BCEL 6.0 and seems to work.
> >
> >
> > Shall we update commons.clirr.version in Commons Parent? It now
> > requires Java 1.7 which I think is OK for mvn site.
> >
> > See also:
> >
> > http://central.maven.org/maven2/org/codehaus/mojo/clirr-
> > maven-plugin/2.8/clirr-maven-plugin-2.8.pom
> > https://github.com/mojohaus/clirr-maven-plugin/releases/tag/
> > clirr-maven-plugin-2.8
> >
> >
> > --
> > Stian Soiland-Reyes
> > http://orcid.org/0000-0001-9842-9718
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> > For additional commands, e-mail: dev-help@commons.apache.org
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message