commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Soroka"<aj...@apache.org>
Subject Re: [RDF] Rename RDFTermFactory to RDFFactory / RDF?
Date Thu, 29 Sep 2016 15:56:27 GMT
I think this is a good idea. It might even be more "generic" to indicate why it includes adaptor
methods. The Banana RDF effort actually uses typeclasses with names like RDF and RDFOps.

---
A. Soroka
Committer/PMC Apache Jena

On 2016-09-15 07:11 (-0400), Stian Soiland-Reyes <stain@apache.org> wrote: 
> Hi,
> 
> Should we rename RDFTermFactory to RDFFactory? Or just RDF? Someone
> suggested that some time ago.
> 
> The reason is that it does quite more than creating RDFTerms, e.g.
> creating triples, graphs and datasets.
> 
> 
> This might make it more obvious why its instances would also include
> 'adaptation' methods from-to the underlying implementations, e.g.
> asJenaNode().
> 
> Example:
> 
> RDF rdf = new JenaRDF();
> IRI iri = rdf.createIRI("http://example.com/");
> Triple triple = rdf.createTriple(iri, iri, iri);
> Graph g = rdf.createGraph();
> g.add(triple);
> 
> 
> We can keep a @Deprecated parent RDFTermFactory interface with the
> 0.2.0 method signatures (and remove it in 1.0.0)
> 
> 
> -- 
> Stian Soiland-Reyes
> http://orcid.org/0000-0001-9842-9718
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message