commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruno P. Kinoshita" <>
Subject Re: Add StringUtils#isAllEmpty(CharSequence...) and isAllBlank(CharSequence...)?
Date Sun, 12 Feb 2017 20:32:04 GMT

I'm 0 on that one. Agree that users can simply use the negation operator, and also that it
can be handy to have a method to avoid typos or simplify their code.


----- Original Message -----
From: Pascal Schumacher <>
To: Commons Developers List <>
Sent: Monday, 13 February 2017 6:12 AM
Subject: Add StringUtils#isAllEmpty(CharSequence...) and isAllBlank(CharSequence...)?

Hello everybody,

a few months ago StringUtils#isAnyNotEmpty(CharSequence...) and 
StringUtils#isAnyNotBlank(CharSequence...) were added 

Now there is a pull request which purposes adding the inverse of these 
methods named isAllEmpty(CharSequence...) and 

Duncan Jones commented on the pull request: "I don't think we should add 
methods that are simply the inverse of another method."

On the other hand similar method "pairs" already exist: 
isEmpty/isNotEmpty, isBlank/isNotBlank, isAnyEmpty/isNoneEmpty, 

What do you think, should we add these methods?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message