commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: [POOL][DBCP] Release plans
Date Mon, 06 Mar 2017 09:06:48 GMT
On 05/03/17 18:21, Matt Sicker wrote:
> I'm also thinking we might want to upgrade to Java 7 for pool 2.5 as dbcp
> 2.x has required it from the beginning. I'm not exactly sure if anything
> JDBC changed in Java 8 to warrant an upgrade to Java 8 for dbcp 2.3, but
> it's also worth mentioning if needed.

Is there any reason - apart from the age of Java 6 - to make Java 7 the
minimum for Pool?

Tomcat 8 uses DBCP 2 and Pool 2 and - because it implements parts Java
EE 7 specification, has to run on Java 7. An upgrade to Java 8 would be
an annoyance but one the Tomcat project could work around if it had to.

Mark

> 
> On 5 March 2017 at 11:59, Pascal Schumacher <pascalschumacher@gmx.net>
> wrote:
> 
>> Great new. :)
>>
>> As far as I remember there were various request for DBCP 2.2 (and we would
>> like to update to pool 2.4.3 at work).
>>
>> Thank you very much,
>> Pascal
>>
>> Am 05.03.2017 um 18:30 schrieb Matt Sicker:
>>
>>> I've started a lazy vote to migrate Pool to Git. After that, I'd like to
>>> take a whack at starting a release candidate for pool 2.4.3. After that,
>>> we
>>> can upgrade DBCP to pool 2.4.3 and do a release of DBCP to 2.2.
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message