commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <ralph.go...@dslextreme.com>
Subject Re: Compiler targets and Java 9
Date Mon, 05 Jun 2017 21:58:14 GMT

> On Jun 5, 2017, at 1:00 PM, Amey Jadiye <ameyjadiye@gmail.com> wrote:
> 
> correct, moving to Java9 might be restricting 1.5 to run on higher
> versions, that said they may not run on java 9 so all this discussion came
> in picture, I wish we can have java 9 target well at the same time we
> should detach our self from java 1.5, just a view.
> 
> Regards,

Java 5 artifacts should run just fine on Java 9 - with the exception that if they are using
restricted classes they will fail.  That is really the only Java 9 issue to be concerned with,
and is why it is going to take quite a bit of time for it to become mainstream.

Ralph



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message