commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <>
Subject [compress] HasCharset is a bad name
Date Wed, 05 Jul 2017 17:14:13 GMT
Hi All,

The new interface name HasCharset is pretty bad IMO.

CharsetProvider is the obvious (to me) better name even though there
already is a class called java.nio.charset.spi.CharsetProvider.

Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message