commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kinow <...@git.apache.org>
Subject [GitHub] commons-text issue #79: Upgrade to JUnit 5.1
Date Sun, 08 Apr 2018 10:34:16 GMT
Github user kinow commented on the issue:

    https://github.com/apache/commons-text/pull/79
  
    Tested the master branch first, and everything obviously worked. Then switched to this
branch, and got an error message, then Eclipse opened the run configuration.
    
    Followed @PascalSchumacher 's suggestion, removed the project JUnit run configurations,
then re-run the class, and everything worked with no issues.
    
    Tested a class, a method, and the entire project, by right clicking each of these, then
Run As -> JUnit Test (i.e. Eclipse also recognized the files as JUnit tests).
    
    Also put a breakpoint in some random method, then Debug As -> JUnit Test, and it worked
as expected too.
    
    Looks good to me. Might be a good idea to wait for @garydgregory 's feedback as I have
very little experience with JUnit 5 for now, besides reading slides/docs/etc.


---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message