commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <>
Subject [parent] Problem with japicmp when building site of [configuration]
Date Sun, 10 Jun 2018 20:10:16 GMT
Hi all,

I tried to update the pom of [configuration] to commons-parent 46. When
I build the site I get the error below.

[configuration] has a number of dependencies marked marked as
<optional>true</optional>. These are obviously not added to the
classpath. I tried to follow the suggestion in the error message to
ignore missing classes by setting the property
commons.japicmp.ignoreMissingClasses to true, but this does not have an

Any ideas how to fix this? Here is my Maven configuration:
$ mvn --version
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5;
Maven home: C:\data\dev\tools\apache-maven-3.3.9
Java version: 1.8.0_144, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.8.0_144\jre
Default locale: de_DE, platform encoding: Cp1252
OS name: "windows 10", version: "10.0", arch: "amd64", family: "dos"

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-site-plugin:3.7:site (default-site) on
project commons-configuration2: Error generating
japicmp-maven-plugin:0.11.1:cmp-report report: Failed to generate
report: Could not load 'Class not found:
org.apache.commons.jxpath.ri.model.NodeIterator. Please make sure that
all libraries have been added to the classpath
or try the option '--ignore-missing-classes'. -> [Help 1]

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message