commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luke Scott (JIRA)" <>
Subject [jira] Created: (FILEUPLOAD-143) "Stream ended unexpectedly"
Date Sun, 05 Aug 2007 06:32:52 GMT
"Stream ended unexpectedly"

                 Key: FILEUPLOAD-143
             Project: Commons FileUpload
          Issue Type: Bug
    Affects Versions: 1.2
         Environment: CentOS 4.4, Jetty running through Red5 (form of Flash Media Server),
code under JSP
            Reporter: Luke Scott

I setup an upload script under a JSP. I tested it by uploading a file via html form upload
and it worked fine - the file was received.

But when I tried uploading the file through a flash interface using the FileReference object
I got a 500 error response. Flash's FileReference API was very vague, and I was unable to
reproduce the error under another interface so I could see the error.... But I finnally did
get something back by writing a catch and writing the error to a file. I don't know if this
is accurate or not:

"Stream ended unexpectedly"

I do know that the error occurs when this line is ran:

List items = upload.parseRequest(request);

And here is some relevant code, but not all of it: (to show that I do have a factory set):

DiskFileItemFactory factory = new DiskFileItemFactory();
ServletFileUpload upload = new ServletFileUpload(factory);
List items = upload.parseRequest(request);

I am fairly sure that flash is doing something that is throwing commons-fileupload off. But
it does work with apache & php...

The biggest difference in the headers, or at least the initial headers, is flash passes a
"connection: close" header.

When searching I came up with some vague answers. This page shows some comments at the bottom
by users with similar problems:

One guy posts a solution to fix the problem, but it seems like it is severely out of date
because where it says "return items;" I do not see items declared in the function of the line
he mentions. Plus he mentions line 336, and it's now on 800 something. Tried his suggestion
but instead returned "true" and "false" (tried both ways) but it didn't work... Also when
I tried his catch line ant said it was invalid, so I had to put "Exception e" instead. You
may notice that his post is in all caps (posts after his appear to be for some reason). I
did make sure to use the proper case (i do know of case sensitivity).

With further reading I read instances where flash did a "test upload" without sending the
file. In other cases I read something about it not sending to blank lines after the header.
Not sure what my current problem is.... I'm sure once the problem is found, it should be fairly
trivial to fix (i hope).

Even though it may be flash's fault, it works in PHP and other instances... So it should work
here :)

Thanks in advance,


This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message