commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard (Commented) (JIRA) <>
Subject [jira] [Commented] (MATH-677) About package "transform"
Date Wed, 04 Jan 2012 03:50:39 GMT


Sébastien Brisard commented on MATH-677:

Moved {{FastFourierTransformer.isPowerOf2(long)}} to {{ArithmeticUtils.isPowerOfTwo(long)}}
in {{r1227042}}.
> About package "transform"
> -------------------------
>                 Key: MATH-677
>                 URL:
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Gilles
>            Assignee: Sébastien Brisard
>            Priority: Minor
>              Labels: api-change
>             Fix For: 3.0
> Classes in package "o.a.c.m.transform" might require some changes in order to conform
to goals set for the next major release.
> Some observations:
> # Exceptions
> ## Should remove use of deprecated "MathRuntimeException"
> ## Should throw more specific "Math...Exception" instances instead of standard IAE
> # Interface "RealTransformer" (and implementations) contain non-conformant method names
(e.g. "inversetransform" instead of "inverseTransform"). {color:red}Fixed in {{r1208293}}.{color}
> # "FastFourierTransformer":
> ## Methods "mdfft" and "verifyDataSet" take an argument of type "Object" (to allow an
argument with an unspecified number of dimensions)
> ## The "RootsOfUnity" helper class could be moved to the "complex" package
> ## For clarity, multidimensional transform should be moved to a class of its own (and
I also wonder whether the "MultiDimensionalComplexMatrix" name is not misleading)
> # "FastFourierTransformer", "FastSineTranformer" and "FastCosineTranformer" define public
methods "tranform2" and "inversetransform2" but they are not part of an interface. {color:red}As
of {{r1213157}}, these methods have been removed, and replaced by factory methods {{create()}}
and {{createUnitary()}} (FFT) or {{createOrthogonal()}} (FCT, FST).{color}
> # Code uses variables that start with an uppercase. {color:red}Fixed, together with various
formatting issues.{color}
> # "FastHadamardTransformer" contains illegible developer documentation (see Javadoc for
protected method "fht"). {color:red}Tried to improve things in {{r1208986}}, but things are
still a bit obscure. Besides, the link provided is broken. Will look into that.{color}

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message