commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonas Sprenger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CHAIN-98) Refactor command interface and base Implementations to enumeration to represent states
Date Wed, 10 Jul 2013 21:35:48 GMT

    [ https://issues.apache.org/jira/browse/CHAIN-98?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13705097#comment-13705097
] 

Jonas Sprenger commented on CHAIN-98:
-------------------------------------

Hi Benedikt,

-	Filter now returns processing.  Actually, I was confused about its name. I wonder if we
could rename it to “PostProcessor”, to prevent confusion about its purpose. What do you
think? 
-	o.a.c.chain.base.DispatchCommand.evaluateResult(Object obj) can return null now, I provided
a test asserting that behavior.
-	ChainBase throws IllegalStateException exception now, a test is as asserting that too.

regards,
Jonas
                
> Refactor command interface and base Implementations to enumeration to represent states
> --------------------------------------------------------------------------------------
>
>                 Key: CHAIN-98
>                 URL: https://issues.apache.org/jira/browse/CHAIN-98
>             Project: Commons Chain
>          Issue Type: Task
>          Components: API
>    Affects Versions: 2.0
>            Reporter: Jonas Sprenger
>            Assignee: Benedikt Ritter
>             Fix For: 2.0
>
>         Attachments: chain-98-2.patch, chain-98-3, chain-98.patch
>
>
> Base implementations should return the constants CONTINUE_PROCESSING or PROCESSING_COMPLETE
instead of returning true or false

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message