commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Bourg (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IMAGING-158) Color component names should follow naming conventions
Date Tue, 03 Feb 2015 15:07:35 GMT

    [ https://issues.apache.org/jira/browse/IMAGING-158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14303401#comment-14303401
] 

Emmanuel Bourg commented on IMAGING-158:
----------------------------------------

The C looks fine to me, it's just the C component of the CMY coordinates. I wouldn't rename
the variables for the same reasons point.x and point.y are better than point.absciss and point.ordinate,
it's shorter and commonly used in this domain.

> Color component names should follow naming conventions
> ------------------------------------------------------
>
>                 Key: IMAGING-158
>                 URL: https://issues.apache.org/jira/browse/IMAGING-158
>             Project: Commons Imaging
>          Issue Type: Improvement
>          Components: imaging.color.*
>            Reporter: Benedikt Ritter
>
> Checkstyle reports a lot of errors because the fields of our color classes are just single
capital letters. I'm currently thinking about renaming them to their full names, so that {{ColorCmy.C}}
becomes {{ColorCmy.cyan}}. Don't know if that feels better from an API user's POV. It's longer
by it's more explicit.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message