commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (VALIDATOR-390) Upgrade to Commons Collections 4.x
Date Sun, 05 Feb 2017 19:55:42 GMT

    [ https://issues.apache.org/jira/browse/VALIDATOR-390?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15853335#comment-15853335
] 

Sebb commented on VALIDATOR-390:
--------------------------------

CC 4.x no longer includes FastHashMap.

Unfortunately it's not possible to replace it as the public API includes references to the
the class.
But even if it were included in CC4 it would break binary compat. because CC4 uses a different
package name.

However the plan is to drop the use of FastHashMap in CV.
This will be binary incompatible so will involve Maven coord and Java package changes.

> Upgrade to Commons Collections 4.x
> ----------------------------------
>
>                 Key: VALIDATOR-390
>                 URL: https://issues.apache.org/jira/browse/VALIDATOR-390
>             Project: Commons Validator
>          Issue Type: Improvement
>            Reporter: Jake Brownell
>            Priority: Minor
>
> Commons Validator 1.5 now uses Java 1.6. Commons Collections 4.0/4.1 has the same Java
requirement.
> I noticed that CV seems to be the only one of many third party dependencies in my project
that requires CC 3.2.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message