commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Juntunen (JIRA)" <>
Subject [jira] [Commented] (GEOMETRY-3) Make Points and Vectors VALJOs
Date Sun, 08 Jul 2018 01:04:00 GMT


Matt Juntunen commented on GEOMETRY-3:

No problem:-)

I chose those names because, at the most general level, the interfaces represent functions
that accept arguments from the real number domain and produce a result. The 2N and 3N suffixes
were the best I could think of to represent the different numbers of arguments. The names
don't follow any convention from the JDK except for the use of the term "Function" to indicate
that the interface method returns a value.

> Make Points and Vectors VALJOs
> ------------------------------
>                 Key: GEOMETRY-3
>                 URL:
>             Project: Apache Commons Geometry
>          Issue Type: Improvement
>            Reporter: Matt Juntunen
>            Assignee: Matt Juntunen
>            Priority: Minor
> Ensure that all Point and Vector classes meet the requirements for being VALJOs as described
here: []. Some of this work has
already been done as part of  GEOMETRY-2. The classes to update are:
>  * o.a.c.geometry.euclidean.oned.Point1D/Vector1D
>  * o.a.c.geometry.euclidean.twod.Point2D/Vector2D
>  * o.a.c.geometry.euclidean.threed.Point3D/Vector3D
>  * o.a.c.geometry.spherical.oned.S1Point
>  * o.a.c.geometry.spherical.twod.S2Point
> Required changes include the following:
>  * Create static factory methods for creating instances using the "of" naming convention.
>  * Make constructors private
>  * Add parse methods to return instances from "canonical" toString representation
>  * Update all uses of the class to use the factory methods instead of the constructor
> Pull request:

This message was sent by Atlassian JIRA

View raw message