commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles Sadowski (Jira)" <>
Subject [jira] [Commented] (COLLECTIONS-728) BloomFilter contribution
Date Wed, 02 Oct 2019 00:07:00 GMT


Gilles Sadowski commented on COLLECTIONS-728:

Thanks for the removal of {{Serializable}}. :)

Class {{BloomCollectionStatistics}}
* enum {{CHANGE}} should be {{Change}} (and the _elements_ must be in uppercase).
* (nit) Javadoc:
** Line lengths in Javadoc seem a bit random.
** Ditto for alignment.
** Inconsistent use of "{@code ...}" (and I would avoid adding an "s" after the closing brace).
* Avoid use of "l" as a variable name.
* Method {{asInt(long)}} would be much clearer using if/else.  Also, might need a better name
({{clampToInteger}} (?))

Class {{BloomFilterConfiguration}}:
* Avoid use of primitive wrapper classes that entail unnecessary boxing/unboxing.
* Remove the multiplication by "1.0" (and unnecessary parentheses)
* (nit) Wrap long lines.

Some of the issues mentioned earlier:
* Add "final" for constants.
* Remove duplicate "build" methods (or please give an example of why they are necessary).
* (nit) Typos in Javadoc and trailing spaces (cf "git diff").

Is {{BloomCollection<T>}} just an example (as stated in the Javadoc) or is it for actual
Do you foresee other implementations of the {{BloomFilter}} interface?  If not, we could rename
{{StandardBloomFilter}} to {{BloomFilter}}...

> BloomFilter contribution
> ------------------------
>                 Key: COLLECTIONS-728
>                 URL:
>             Project: Commons Collections
>          Issue Type: Task
>            Reporter: Claude Warren
>            Priority: Minor
> Contribution of BloomFilter library comprising base implementation and gated collections.

This message was sent by Atlassian Jira

View raw message