cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John M. Wargo (JIRA)" <>
Subject [jira] [Commented] (CB-3568) Path problem with Android SDK installation
Date Tue, 04 Jun 2013 11:05:20 GMT


John M. Wargo commented on CB-3568:

I had to do a "sudo npm install -g cordova". It wouldn't run by just doing "npm install -g

Yesterday I tried copying the Android SDK folder to /Applications. It fixed that error, but
still failed with a different error. Since I can't post screen shots here, I didn't grab a
shot of the error. Shouldn't there be a way to generate a log of cordova.s output so I can
simply paste the activity here?  I tried "cordova... > textfile.txt" but the file it generates
is mostly unreadable.

Add a 'log' switch to the command line which causes it to generate a log that I can then grab
and put here to help with troubleshooting.
> Path problem with Android SDK installation
> ------------------------------------------
>                 Key: CB-3568
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI
>    Affects Versions: 2.7.0
>         Environment: Mac OS X
>            Reporter: John M. Wargo
>            Assignee: Filip Maj
> I downloaded the android sdk and extracted it to my downloads folder then added the platform-tools
and tools folders to the path environment. When I create a project and issue a cordova platform
add android, a bunch of stuff happens then eventually I receive an error message indicating
that the process couldn't find the build.xml, but it's looking for the file in /Applications/android-sdk-macosx/tools/ant/build.xml
which is not where my files are located.
> It looks like the cordova cli is forcing an absolute path for the Android SDK - looking
for it in Applications instead of where I have it. The Android SDK instructions for Max OSX
don't say to copy the files to Applications nor does the readme for the Cordova CLI in 2.7.
> I have a screen shot of this, couldn't find the output anywhere that I could past in

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message