cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Husting (JIRA)" <>
Subject [jira] [Commented] (CB-7665) Release process for Google Play has no documentation, requires guesswork!
Date Fri, 03 Oct 2014 16:34:34 GMT


Steve Husting commented on CB-7665:

1. I created a text file called and saved it in the root myApp/ folder. I copied
my .keystore to the same folder. The contents of the file:

# = path/to/.keystore file
# key.alias = alias

2. I ran in the terminal:

$ cd myApp/platforms/android
$ ant release

... and got the message:

/Users/Steve/Documents/AndroidApps/myApp/platforms/android/build.xml:55: sdk.dir is missing.
Make sure to generate using 'android update project' or to inject it through
the ANDROID_HOME environment variable.

3. I don't understand how to formulate the recommended command: 

android update project --path 

> Release process for Google Play has no documentation, requires guesswork! 
> --------------------------------------------------------------------------
>                 Key: CB-7665
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: Android, CLI, Docs
>    Affects Versions: 3.5.0
>         Environment: Mac OS X Lion
>            Reporter: Steve Husting
>              Labels: patch
>             Fix For: 3.5.0
> I output my myApp version 12 project with: cordova build android --release
> It was output as myApp/platforms/android/ant-build/myApp-release-unsigned.apk
> I changed the name to the final apk name: myApp-release-unsigned.apk = myApp.apk
> I copied the myApp.keystore file used on earlier myApps to the same folder. 
> Starting with that folder, I ran: jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1
-keystore myApp.keystore myApp.apk myApp
> I successfully verified it with: jarsigner -verify -verbose -certs myApp.apk
> When I uploaded the myApp.apk to Google Play, it said that the file needed to be zipaligned.
> The verbose output shows zipalign being done. So is there a bug when the apk is made
via cordova build android --release? 
> Is there a step missing that I should be taking? Unfortunately, all the instructions
for this on the Internet assume I'm not using Cordova. 

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message