cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-7698) CLI: no validation for globally required plugin variables
Date Thu, 02 Oct 2014 15:14:33 GMT

    [ https://issues.apache.org/jira/browse/CB-7698?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14156652#comment-14156652
] 

ASF subversion and git services commented on CB-7698:
-----------------------------------------------------

Commit 242a8d760267379e963977de68d49aae96928562 in cordova-lib's branch refs/heads/master
from [~bhiggins_bb]
[ https://git-wip-us.apache.org/repos/asf?p=cordova-lib.git;h=242a8d7 ]

CB-7698 CLI - Validate top-level plugin variables before installing


> CLI: no validation for globally required plugin variables
> ---------------------------------------------------------
>
>                 Key: CB-7698
>                 URL: https://issues.apache.org/jira/browse/CB-7698
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: CLI
>            Reporter: Bryan Higgins
>            Assignee: Bryan Higgins
>            Priority: Minor
>
> CLI should check that any globally required variables (preference at root level in plugin.xml)
have been provided before calling plugman.install on the platforms. Otherwise the plugin is
added to the project but plugman fails to install to any platforms.
> From the docs:
> plugman checks that these required preferences are passed in. If not, it should warn
the user how to pass the variable in and exit with a non-zero code.
> http://cordova.apache.org/docs/en/3.6.0/plugin_ref_spec.md.html#Plugin%20Specification



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message