cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Santana (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CB-9955) Cordova CLI to have outdated command
Date Wed, 04 Nov 2015 23:00:28 GMT
Carlos Santana created CB-9955:
----------------------------------

             Summary: Cordova CLI to have outdated command
                 Key: CB-9955
                 URL: https://issues.apache.org/jira/browse/CB-9955
             Project: Apache Cordova
          Issue Type: Bug
          Components: CLI
    Affects Versions: Master
            Reporter: Carlos Santana


I would like to have a cordova command "outdated"
It will be similar to "npm outdated" https://docs.npmjs.com/cli/outdated

But tailor to cordova projects
It will print columns with versions for platforms and plugins present in the project and the
cli
For each one will print the following columns
- Current (the current version)
- Wanted (meaning is there is a plugin or platform specified in config,xml)
- Latest (latest available from npm registry)
- Pinned (the version that is pinned to the current cordova cli running the command)

If pacakge name starts with "cordova-" it will be removed printing the rest

$cordova outdated
Package          Current     Wanted   Latest  Pinned
-----------           ----------    -----------   --------- ----------
cli                      5.3.3        N/A         5.4.0    N/A
ios                     3.8.0        3.9.1       3.9.2   3.9.0 
android              .....
plugin-camera   ....
plugin-device    ....






--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message