cordova-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-14263) Makes all of cordova plugins compatible with cordova-android 7
Date Wed, 05 Sep 2018 10:18:00 GMT

    [ https://issues.apache.org/jira/browse/CB-14263?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16604233#comment-16604233
] 

ASF GitHub Bot commented on CB-14263:
-------------------------------------

janpio commented on issue #35:  CB-14263: (android) make cordova plugin compatible with cordova-android
7
URL: https://github.com/apache/cordova-common/pull/35#issuecomment-418678277
 
 
   I fixed an Javascript problem eslint was complaining about. Now the tests complain about
real test failures Can you take a look please @leo6104? Thanks.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Makes all of cordova plugins compatible with cordova-android 7
> --------------------------------------------------------------
>
>                 Key: CB-14263
>                 URL: https://issues.apache.org/jira/browse/CB-14263
>             Project: Apache Cordova
>          Issue Type: Improvement
>          Components: AllPlugins, cordova-android, cordova-common
>    Affects Versions: cordova-common@2.2.3
>            Reporter: Heo
>            Priority: Major
>             Fix For: Master
>
>   Original Estimate: 12h
>  Remaining Estimate: 12h
>
> Cordova common's ConfigParser supports alias such as config.xml, AndroidManifest.xml
paths. [https://github.com/apache/cordova-common/blob/7bf9627f0135c6b3518292660b6e07e6f5815926/src/ConfigChanges/ConfigFile.js#L192] But
In PluginInfo parser, there is no alias rules for compatibility.
> There is lots of cordova plugins still not upgrade to cordova-android 7 syntax (plugin.xml)
> So i did some changes to cordova-common which will make cordova cli parsing some plugins
which not support cordova-android 7 yet.
> [https://github.com/apache/cordova-cli/compare/master...leo6104:master]
> Here is my changes.
>  
>  
> I spent lots of times to fix this. I test it via my cutsom cordova-cli repository [https://github.com/leo6104/cordova-cli/] and
i fix it in my cordova project.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org


Mime
View raw message